守望的麦子

gensim Installation

2015-8-28    大连 /python/2015/08/28/gensim.html python

Python 是一门优雅而健壮的编程语言,它继承了传统编译语言的强大性和通用性,同时也借鉴了简单脚本和解释语言的易用性。

Python 编程简明教程 https://wheat.at/python/

版本要求

Python >= 2.6. Tested with versions 2.6, 2.7, 3.3 and 3.4. Support for Python 2.5 was discontinued starting gensim 0.10.0; if you must use Python 2.5, install gensim 0.9.1.
NumPy >= 1.3. Tested with version 1.9.0, 1.7.1, 1.7.0, 1.6.2, 1.6.1rc2, 1.5.0rc1, 1.4.0, 1.3.0, 1.3.0rc2.
SciPy >= 0.7. Tested with version 0.14.0, 0.12.0, 0.11.0, 0.10.1, 0.9.0, 0.8.0, 0.8.0b1, 0.7.1, 0.7.0.

安装 NumPy

下载地址:https://sourceforge.net/projects/numpy/

安装 SciPy

下载地址:https://sourceforge.net/projects/scipy/

安装 gensim

下载地址:https://pypi.python.org/pypi/gensim

解压,执行

python setup.py install

完成。

Windows 用户

对于 Windows 用户,比较方便的方法是安装集成了 Python & NumPy & SciPy 的 bundle。例如 Enthought CanopyWinPython 或者 Anaconda 等等。[via1,via2]

参考链接:
Official Installation Instruction: https://radimrehurek.com/gensim/install.html

关于作者
麦子,80 后,现从事通信行业。安卓玩家一个人的书房朗读者。
MRJENGLISH
jsntn
jasonwtien
jasonwtien
更多…… /about.html

最近更新: